Network: Sponsored Guest Registration

Summary

Instructions for sponsoring a guest device on the NMSU network.

Body

Overview

This service allows guests without authorized login credentials to register their devices on the NMSU's Guest Network. Any device that uses a wireless or wired connection, such as mobile devices, laptops, computers, routers, or gaming systems, can be registered. 

Before you begin

An NMSU user must complete the steps below directly on the guest device. If you are registering a mobile device, disable MAC Randomization first by following the instructions in Network: Disable MAC Randomization.

Procedure

Step 1

Connect to AggieAir and follow this link to begin registering a guest device. 

 

Step 2

Follow the onscreen instructions to configure and register the computer for DHCP. 

Note: For mobile devices (Xbox, Blackberry, iPod, iPhone, etc.), contact the IT Helpdesk for DHCP setup.

 

Step 3
Review and accept the New Mexico State University Network terms of use, then select Sponsor a Guest. 

 

Step 4
Continue following the onscreen instructions to complete the process. 

If You're Still Experiencing Issues

Submit a ticket to the IT Help Desk here 

Contact Information:

IT Help Desk Contact & Zoom Desk
In Person: Hardman & Jacobs Undergraduate Learning Center - Room 105
Phone: (575) 646-HELP (4357)

Email: help@nmsu.edu



Zoom Link:
https://nmsu.zoom.us/my/nmsuithelpdesk
Or meeting ID: nmsuithelpdesk
Zoom with us M-F 8am-5pm

Details

Details

Article ID: 20688
Created
Sun 1/4/26 11:18 PM
Modified
Sun 1/4/26 11:18 PM
Environment
What service, system, process, application, or product could be impacted? Has anything changed in the environment recently? Environment statements are specific to the issue and resolution, and are true before and after resolution.
NMSU Network
Cause
The underlying source of the issue.
Guest Network